Установить cURL на VMBitrix / bitrix virtual appliance

Делал интеграцию для amoCRM, понадобилось использовать библиотеку cURL на VMBitrix.

Порядок действий такой:

  1. Подключаемся по SSH. Выходим из меню Битрикс окружения.
  2. Устанавливаем библиотеку:
    yum install php-curl
  3. Сначала cURL отключена. Поэтому переименовываем файл командой:
    mv /etc/php.d/curl.ini.disabled /etc/php.d/curl.ini 
  4. Перезапускаем Apache
    /etc/init.d/httpd restart

Готово!

Добавление внешних отчетов в 1С. УНФ

Добавление отчета в конфигурацию «1С. Управление нашей фирмой» отличается от Бухгалтерии. Там появились тэги. Теперь при создании внешнего отчета желательно указать тэги.
Ниже пример кода из модуля объекта и картинка, на которой показано местонахождение тега. Так же в отчет необходимо добавить реквизит «ЭтоОтчетУНФ» (Тип: Булево).

//
// Уже привычная нам функция для внешней обработки
Функция СведенияОВнешнейОбработке() Экспорт
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.3.1.73");
	ПараметрыРегистрации.Информация = НСтр("ru = 'Отчет по Фондам. Поддержка - help1c.su.'");
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиОтчет();
	ПараметрыРегистрации.Версия = "2020.10.23";
	ПараметрыРегистрации.Наименование = "Распределение по фондам";
	
	Команда = ПараметрыРегистрации.Команды.Добавить();
	Команда.Представление = НСтр("ru = 'Распределение по фондам'");
	Команда.Идентификатор = "РаспределениеПоФондам";
	Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	Команда.ПоказыватьОповещение = Истина;
	
	
	Возврат ПараметрыРегистрации;
КонецФункции

// А в этой функции мы указываем Тэги через запятую.
// Больше примеров в модулях объекта стандартных отчетов УНФ
Процедура ПриОпределенииНастроекОтчета(НастройкиОтчета, НастройкиВариантов) Экспорт
	
	Для Каждого НастройкиТекВарианта Из НастройкиВариантов Цикл
		НастройкиТекВарианта.Значение.Теги = НСтр("ru = 'Деньги,CRM'");
	КонецЦикла;
	
КонецПроцедуры

// Упомянутый реквизит
ЭтоОтчетУНФ = Истина;

Пример отображения отчета с тегом Деньги

Добавить счет 76.01.9 в акт сверки расчетов

Понадобилось в акт сверки добавить операции по счету 76.01.9 «Платежи (взносы) по прочим видам страхования». Простое добавление счета на закладке «Счета учетов расчетов» не помогло. В акт попадают операцию только тех счетов, у которых есть субконто «Контрагенты» и «Договоры». Поэтому нужно добавить субконто «Договоры» счету 76.01.9, в акте добавить счет на закладке «Счета учетов расчетов» и акт будет заполняться.

1С. Примеры работы с уникальным идентификатором (UUID, ГУИД, GUID)

Пример уникального идентификатора: 4bf85396-cc7a-11ea-9ef0-c86000245adb

   //
   //Узнать уникальный идентификатор
   ГУИД = КонтрагентСсылка.УникальныйИдентификатор();

   //Создаём уникальный идентификатор из строки
   СтрокаGUID = "4bf85396-cc7a-11ea-9ef0-c86000245adb";
   НовыйGUID = Новый УникальныйИдентификатор(СтрокаGUID);

   //Можно не указывать СтрокаGUID. Программа сгенерирует сама
   НовыйGUID = Новый УникальныйИдентификатор();

   //
   //Получить ссылку на на объект, зная его GUID
   СсылкаПП = Документы.ПлатежноеПоручениеВходящее.ПолучитьСсылку(НовыйGUID);	

   //Создать документ и присвоить ему ГУИД
   СтрокаGUID = "4bf85396-cc7a-11ea-9ef0-c86000245adb";
   Док = Документы.ПлатежноеПоручениеВходящее.СоздатьДокумент();
   СсылкаДок = Документы.ПлатежноеПоручениеВходящее.ПолучитьСсылку(Новый УникальныйИдентификатор(СтрокаGUID));
   Док.УстановитьСсылкуНового(СсылкаДок);    
   //
   //Получить ГУИД из COM-объекта
   V83COMConnector = Новый COMОбъект("V83.COMConnector");		
   БД = V83COMConnector.Connect(ПараметрыПодключения);   
   СтрокаГУИД = БД.XMLСтрока(Док.Ссылка);

Свойство отчета Хранилище вариантов не заполнено

При добавлении внешнего отчета в 1С вы получаете сообщение

Свойство отчета «Хранилище вариантов» не заполнено.
Сохранение (выбор) вариантов отчета будет работать в ограниченном режиме.
Обратитесь к разработчику дополнительного (внешнего) отчета.

Читать далее Свойство отчета Хранилище вариантов не заполнено

Полный свод начислений, удержаний и выплат без разбивки по месяцам

По умолчанию отчет «Полный свод начислений, удержаний и выплат» разбивается на таблицы по месяцам. Как сделать отчет за произвольный период и при этом получить корректное сальдо? Читать далее Полный свод начислений, удержаний и выплат без разбивки по месяцам

Как сделать отбор в регистре сведений 1С

Отбор доступен для измерений и реквизитов, у которых установлено свойство «Индексировать» или стоит флажок «Ведущее». По ресурсам отбор делать нельзя. Читать далее Как сделать отбор в регистре сведений 1С

Ошибка «Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости»

Начиная с платформы 8.3.14 при работе в старых конфигурациях появляется ошибка «Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости.» Читать далее Ошибка «Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости»