Установить cURL на VMBitrix / bitrix virtual appliance

Делал интеграцию для amoCRM, понадобилось использовать библиотеку cURL на VMBitrix.

Порядок действий такой:

  1. Подключаемся по SSH. Выходим из меню Битрикс окружения.
  2. Устанавливаем библиотеку:
    yum install php-curl
  3. Сначала cURL отключена. Поэтому переименовываем файл командой:
    mv /etc/php.d/curl.ini.disabled /etc/php.d/curl.ini 
  4. Перезапускаем Apache
    /etc/init.d/httpd restart

Готово!

Добавление внешних отчетов в 1С. УНФ

Добавление отчета в конфигурацию «1С. Управление нашей фирмой» отличается от Бухгалтерии. Там появились тэги. Теперь при создании внешнего отчета желательно указать тэги.
Ниже пример кода из модуля объекта и картинка, на которой показано местонахождение тега. Так же в отчет необходимо добавить реквизит «ЭтоОтчетУНФ» (Тип: Булево).

//
// Уже привычная нам функция для внешней обработки
Функция СведенияОВнешнейОбработке() Экспорт
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.3.1.73");
	ПараметрыРегистрации.Информация = НСтр("ru = 'Отчет по Фондам. Поддержка - help1c.su.'");
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиОтчет();
	ПараметрыРегистрации.Версия = "2020.10.23";
	ПараметрыРегистрации.Наименование = "Распределение по фондам";
	
	Команда = ПараметрыРегистрации.Команды.Добавить();
	Команда.Представление = НСтр("ru = 'Распределение по фондам'");
	Команда.Идентификатор = "РаспределениеПоФондам";
	Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	Команда.ПоказыватьОповещение = Истина;
	
	
	Возврат ПараметрыРегистрации;
КонецФункции

// А в этой функции мы указываем Тэги через запятую.
// Больше примеров в модулях объекта стандартных отчетов УНФ
Процедура ПриОпределенииНастроекОтчета(НастройкиОтчета, НастройкиВариантов) Экспорт
	
	Для Каждого НастройкиТекВарианта Из НастройкиВариантов Цикл
		НастройкиТекВарианта.Значение.Теги = НСтр("ru = 'Деньги,CRM'");
	КонецЦикла;
	
КонецПроцедуры

// Упомянутый реквизит
ЭтоОтчетУНФ = Истина;

Пример отображения отчета с тегом Деньги

Свойство отчета Хранилище вариантов не заполнено

При добавлении внешнего отчета в 1С вы получаете сообщение

Свойство отчета «Хранилище вариантов» не заполнено.
Сохранение (выбор) вариантов отчета будет работать в ограниченном режиме.
Обратитесь к разработчику дополнительного (внешнего) отчета.

Читать далее Свойство отчета Хранилище вариантов не заполнено

Как сделать отбор в регистре сведений 1С

Отбор доступен для измерений и реквизитов, у которых установлено свойство «Индексировать» или стоит флажок «Ведущее». По ресурсам отбор делать нельзя. Читать далее Как сделать отбор в регистре сведений 1С

Ошибка «Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости»

Начиная с платформы 8.3.14 при работе в старых конфигурациях появляется ошибка «Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости.» Читать далее Ошибка «Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости»

Версия компоненты ‘comcntr’ отличается от версии корневого модуля

Если вы получили следующую ошибку:

Произошла исключительная ситуация (V83.COMConnector.1): Версия компоненты ‘comcntr’ (8.3.13.1690) отличается от версии корневого модуля ‘core83’ (8.3.13.1865)

Нужно зарегистрировать файл C:\Program Files\1cv8\Номер версии платформы\bin\comcntr.dll.

Запустите командную строку с правами администратора и выполните следующую команду:

C:\Windows\System32\regsvr32.exe "C:\Program Files (x86)\1cv8\8.3.13.1865\bin\comcntr.dll"

Обратите внимание на разрядность операционной системы!

После перезагрузки сервера не запускается служба Агент сервера 1С:Предприятия 8.3. Занят порт

Проблема: После перезагрузки сервера не запускается служба «Агент сервера 1С:Предприятия 8.3».

Одна из возможных причин: Порт 1540 занят другим процессом Читать далее После перезагрузки сервера не запускается служба Агент сервера 1С:Предприятия 8.3. Занят порт

Нельзя установить область действия расширения конфигурации…

При сохранении расширения конфигурации вы получаете ошибку:

«Нельзя установить область действия расширения конфигурации в значение РазделениеДанных в информационной базе, не использующей разделение данных»

Читать далее Нельзя установить область действия расширения конфигурации…